IBM AIX 的 uspchrp 命令触发本地缓冲区溢出漏洞 « 黑客联盟[民间 公益 非盈利团队]尚武精神

首页 » 黑客新闻 » 最新漏洞 » IBM AIX 的 uspchrp 命令触发本地缓冲区溢出漏洞

IBM AIX 的 uspchrp 命令触发本地缓冲区溢出漏洞

10-09-29 14:47 0 RSS 2.0

受影响系统:
IBM AIX 5.3
IBM AIX 5.2

描述:
IBM AIX是一款商业性质的UNIX操作系统。

AIX的uspchrp命令工具实现上存在缓冲区溢出漏洞,本地攻击者可能利用此漏洞提升权限。

uspchrp是AIX诊断子系统中的一个命令。如果本地攻击者执行了以下命令的话:

        /usr/lpp/diagnostics/bin/uspchrp

就可能触发缓冲区溢出,导致以root用户权限执行任意指令。但本地攻击者必须为system组的成员才能执行有漏洞的命令。

厂商补丁:
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

ftp://aix.software.ibm.com/aix/efixes/security/uspchrp_fix.tar

联系我 Contact Me

回到页首